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LESSON SKILL MATRIX

 Skill Exam Objective Objective Number

 Validating Content by Using Spelling Set grammar. 5.1.1
  and Grammar Checking Options Set style options. 5.1.2

 Confi guring AutoCorrect Settings Add or remove exceptions. 5.2.1
  Turn AutoCorrect on and off. 5.2.2

 Inserting and Modifying Comments Insert a comment. 5.3.1
  in a Document Edit a comment. 5.3.2
  Delete a comment. 5.3.3

 Viewing Comments View comments. 5.3.4

KEY TERMS
• AutoCorrect

• balloons

• inline

• markup

Proofi ng Documents 9
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 238 Lesson 9

Blue Yonder Airlines is a large company with hundreds of employees. In your job 

as a human resources specialist, you are involved in hiring, employee benefi t pro-

grams, and employee communications. Many of the documents you work with 

relate to employee issues, and you need to ensure that these documents are error 

free. In this lesson, you will learn to use the spelling and grammar feature, insert 

comments, and change the AutoCorrect settings.

SOFTWARE ORIENTATION

The Proofi ng and Language Groups

The Proofi ng group contains commands for launching Word’s spelling and grammar functions, 
searching through references, using the Thesaurus, and counting words by characters, para-
graphs, and lines. The Language group contains commands for translating words or paragraphs 
and an option to select a language. These and other commands for reviewing and editing Word 
documents are located on the Review tab, shown in Figure 9-1.

Figure 9-1

Proofi ng and Language groups

Opens the Research 
Task Pane

Launches the Spelling & 
Grammar dialog box

Translates words or 
paragraphs into a 
different language

Language Options

Word count is 
located on 
status bar. 

Word automatically checks the document for 
errors. A blue check mark indicates the 
document is error free; a red check mark 
indicates there are errors.

Use this fi gure as a reference throughout this lesson and the rest of this book.

c09ProofingDocuments.indd Page 238  01/08/11  10:06 AM user-f396c09ProofingDocuments.indd Page 238  01/08/11  10:06 AM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE



 Proofi ng Documents 239

VALIDATING CONTENT BY USING SPELLING
AND GRAMMAR CHECKING OPTIONS
It is a good business practice to proof a document to ensure it is error free before sharing or 
printing it. Word provides proofi ng tools such as a Spelling and Grammar checking function, 
Thesaurus, Word Count tracker, and a Research tool that provides searchable access to reference 
books and online research and business sites. All of these tools and commands are located on the 
Ribbon on the Review tab. The status bar also contains Word Count and Proofi ng Error but-
tons that give you quick access to some proofi ng features. On the status bar, Word automatically 
displays the document’s word count.

Using the Spelling and Grammar Feature
Word’s Spelling and Grammar feature automatically checks the spelling and grammar in a docu-
ment. Word underlines misspelled words with a wavy red line and underlines grammatical errors 
with a wavy green line. Word will also detect if words are used inappropriately and it underlines 
the word with a wavy blue line. In other words, the word is in the dictionary but not used cor-
rectly in the context. In this exercise, you learn to use Word’s automatic Spelling and Grammar 
feature and its options to proof and correct your document.

The Bottom Line

STEP BY STEP Check Spelling and Grammar

GET READY. Before you begin these steps, LAUNCH Microsoft Word and OPEN the 
employ_offer document that is in your lesson folder.

 1. Click the Review tab and, in the Proofi ng group, click the Spelling & Grammar button. 
The Spelling and Grammar dialog box opens.

 2. Click the Options button in the Spelling and Grammar dialog box; the Word Options 
dialog box opens in Backstage view, as shown in Figure 9-2. Select Proofi ng in the left 
pane and, in the When Correcting Spelling and Grammar in Word section, click the 
Writing Style drop-down arrow and use the Grammar Only default to set the tool for 
checking the document’s grammar, but not its writing style. Click OK to apply your 
changes and to launch the Spelling and Grammar tool.

          The employ_offer 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

WileyPLUS Extra! features an 
online tutorial of this task.

Figure 9-2

Word Options in Backstage 
view Spelling and Grammar 

dialog box

Default Settings

Click drop-down 
arrow to change 
Writing Style.

Customize the grammar and 
set style guidelines.

Word provides 
suggested 
corrections. 

Misspelled words are 
highlighted in red. Ignores the 

selected instance 
and stops at the 
next occurrence.

Ignores all 
occurrences in 
the document

Words can be 
added to the 
custom dictionary.

Changes the 
misspelled word

Changes all occurrences 
of the misspelled word 
throughout the document
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 240 Lesson 9

3. The fi rst word the tool highlights is Sheela, a proper noun not contained in the tool’s 
dictionary. The Spelling and Grammar dialog box opens, with the potential error 
identifi ed in the upper pane as Not in Dictionary (see Figure 9-3). With the correct 
spelling highlighted in the Suggestions pane, click the Change All button to correct all 
occurrences of the misspelling.

Figure 9-3

Spelling and Grammar
dialog box

4. The word confi m is misspelled; with the correct spelling highlighted in the 
Suggestions pane, click the Change All button.

5. The next misspelled word is begining. Click the Change All button.

6. The next misspelled word is asistance. Click the Change All button. A prompt will 
appear when the Spelling and Grammar check is complete. Click OK.

7. Word has the option for users to ignore misspelled words. In this case, the previous user 
ignored misspellings. You will be rechecking the document to ensure you have captured all 
errors. Click the File tab, then Options to open the Word Options dialog box in Backstage.

 8. Select Proofi ng in the left pane and, in the When Correcting Spelling and Grammar 
in Word section, click the Recheck Document button. A prompt appears stating This 
operation resets the spelling checker and the grammar checker so that Word will 
recheck words and grammar you previously checked and chose to ignore. Do you 
want to continue? Click Yes (see Figure 9-4). The document fl ags misspellings.

Figure 9-4

Microsoft Word
resets spelling and

grammar checker

9. In the Proofi ng group, click the Spelling and Grammar button. The Spelling and 
Grammar dialog box opens.

10. The Spelling and Grammar tool next highlights Suurs. This spelling is correct, so click 
Ignore All. The tool now will ignore every occurrence of this spelling in the document.

Ignore Once will ignore the occurrence once and will stop at the next occurrence.

11. The next misspelled work is employmet; again, click the Change All button to correct 
all occurrences. A prompt will appear when the Spelling and Grammar check is 
complete. Click OK.

When Word detects a spelling error, you can choose to change one occurrence of the instance 
or change all instances. Click Change to change a single occurrence or click Change All to 
Change all occurrences in the document.

12. SAVE the document as employment_offer in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Take Note

Take Note

 Another Way
 Click the Proofi ng 
Error button on the status bar 
(or press the keyboard shortcut, 
F7). Word displays a shortcut 
menu with suggested words.
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 Proofi ng Documents 241

If you run the Spelling and Grammar command in the middle of the document, it will check 
from that point to the end of the document. A prompt will appear asking if you want to con-
tinue checking the document from the beginning.

Changing the Grammar Settings
Word’s grammar settings enable you to determine the punctuation and other stylistic guidelines 
by which the program will check for and detect errors. You can change the writing style to check 
for grammar only or check stylistic rules, such as contractions, hyphenated and compound 
words, sentence length (more than 60 words), and more. In this exercise, you learn to change 
the style settings and customize them to meet your needs.

STEP BY STEP Change the Grammar Settings

USE the document from the previous exercise.

1. Click the File tab and then Options to open the Word Options dialog box in Backstage.

2. Select Proofi ng in the left pane and in the When Correcting Spelling and Grammar 
in Word section, click the Settings button to open the Grammar Settings dialog box. 
This dialog box lists the writing style where you can customize the Grammar Only or 
Grammar & Style (see Figure 9-5).

Take Note

Figure 9-5

Grammar Settings
dialog box Check for Grammar Only 

or Grammar & Style.

Use the scroll bar to 
view the Styles options 
and enable.

You can enforce the 
spacing between 
sentences from 1 to 2.

3. Click the drop-down arrow in the Writing Style section and select Grammar & Style.

4. Under the Require section, the Spaces required between sentences setting is set to 
don’t check. Click the drop-down arrow and select 2. You are changing the style to 
refl ect two spaces after the punctuation between each sentence. Click OK.

5. In the Word Options dialog box, under When Correcting Spelling and Grammar in 
Word section, click the Recheck Document button, then click OK. A prompt appears 
stating that This operation resets the spelling checker and the grammar checker so 
that Word will recheck words and grammar you previously checked and chose to 
ignore. Do you want to continue? Click Yes. Click OK to close the Word Options dialog 
box. Word fl ags and marks the punctuation at the end of sentences with a green wavy 
line. Notice in the second paragraph, the document fl ags “are issued.” Right-click on 
the phrase and a pop-up menu appears. It states “Passive Voice (consider revising).”

 6. Repeat steps 1 and 2 to open the Grammar Settings dialog box.

 7. Under the Require section, click the drop-down arrow to change the Spaces required 
between sentences setting to don’t check.

 8. Scroll down and disable all styles with the exception of Clichés, Colloquialisms, and 
Jargons. One style is kept active. Click OK.

 9. In the Word Options dialog box, under the When Correcting Spelling and Grammar 
in Word section, click the Recheck Document button. A prompt appears stating that 
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 242 Lesson 9

5.1.1

How do you set 
grammar options?

5.1.2

How do you change the
style options?

This operation resets the spelling checker and the grammar checker so that Word will 
recheck words and grammar you previously checked and chose to ignore. Do you 
want to continue? Click Yes. Click OK to close the Word Options dialog box. Notice 
“are issued” in the second paragraph is no longer fl agged. In the third paragraph, the 
phrase “in the amount of” is fl agged with a wavy line.

 10. When you right-click on the phrase, the pop-up menu appears. Click About This 
Sentence. The Help menu appears, indicating this is a cliché and the marked word or 
phrase may be overused or unnecessary to the meaning of your sentence. To remove 
it, you would repeat steps 6–9 to disable Clichés, Colloquialisms, and Jargons.

 11. Click the Options button in the Spelling and Grammar dialog box; the Word Options 
dialog box opens in Backstage view. Select Proofi ng in the left pane and, in the When 
Correcting Spelling and Grammar in Word section, click the Writing Style command 
box drop-down arrow and select Grammar Only to set the tool for checking the 
document’s grammar. Click OK to apply your changes.

 12. SAVE your document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

CONFIGURING AUTOCORRECT SETTINGS
The Proofi ng pane of the Word Options dialog box also contains Word’s AutoCorrect setting 
options. AutoCorrect is a feature that replaces symbols, commonly misspelled words, and ab-
breviations for specifi c text strings. For instance, to add the Trademark symbol, key (TM) and it 
automatically inserts the symbol ™. The bottom line, AutoCorrect saves time in keying text. 
You can manage the list of exceptions in the AutoCorrect Exceptions dialog box, such as not 
capitalizing the fi rst letter of an abbreviation; for example, etc. You can disregard two initial caps, 
such as a student ID, or you can customize and add or delete text. AutoCorrect is on by default, 
but you can use the AutoCorrect options to disable or enable the feature. In this lesson, you 
learn to use AutoCorrect to replace text and insert symbols in your document, and you practice 
turning the AutoCorrect feature on and off.

STEP BY STEP Confi gure AutoCorrect Options

USE the document from the previous exercise.

 1. Click the File tab to open the Backstage view.

 2. Click the Options button to display the Word Options dialog box.

 3. Click Proofi ng on the left pane to display the Proofi ng options in the right pane of the 
screen.

 4. Click the AutoCorrect Options button to display the AutoCorrect dialog box with the 
AutoCorrect tab open, as shown in Figure 9-6. Notice that the dialog box title indicates 
that the program is set to check and correct text based on U.S. English.

The Bottom Line

Figure 9-6

AutoCorrect dialog box
Default settings for 
AutoCorrect.  To disable, 
click the appropriate 
check box.

As you key text, it 
will automatically 
be corrected.

When keying a text 
string, it automatically 
changes in your 
document.

You can add your own 
AutoText elements here. 

All AutoText (common 
misspellings, 
acronyms, symbols, 
etc.) and replacements 
are listed here.

AutoCorrect Exceptions 
dialog box allows you to 
manage the exceptions.
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5. You want AutoText to replace the typed abbreviation BYA, with the full name, Blue 
Yonder Airlines, so you can save time keying in text. In the Replace box, key BYA. In 
the With box, key Blue Yonder Airlines.

6. Check that you have spelled the replacement text correctly, then click the Add button 
to add your AutoText replacement to the list. Click OK to close the AutoCorrect 
dialog box, and then click OK to close the Word Options dialog box and return to 
your document.

 7. In the fi rst paragraph at end of the fi rst sentence, place your insertion point after r in 
for and press the Spacebar once.

 8. Key BYA and press the Spacebar once. BYA is replaced with Blue Yonder Airlines. 
Delete the extra space before the punctuation.

 9. Repeat steps 1–4 to open the AutoCorrect Options dialog box.

 10. In the Replace box, key BYA. BYA and Blue Yonder Airlines are highlighted in the list 
of AutoText exceptions, as shown in Figure 9-7. Click the Delete button to remove the 
highlighted entries. Now, if you key BYA in your document and press the Spacebar, no 
action will occur.

5.2.1

How do you add a word
to AutoCorrect?

 Another Way
 You also can use 
the Find and Replace command 
to replace words or phrases.

5.2.1

How do you delete a word or 
phrase from AutoCorrect?

Click the Delete button 
to remove word.

BYA. Notice it 
appears below.

Figure 9-7

AutoCorrect dialog box

11. SAVE the fi le as employment_offer1 in your USB fl ash drive in the lesson folder.

12. Double-click the Blue Yonder Airlines header to open the Header and Footer Tools 
Design tab. Place your insertion point after the s in Airlines in the heading. Blue Yonder 
Airlines is the trademark name for the company and requires the trademark symbol 
after the name.

13. Key (TM) to insert the trademark symbol after Airlines. Insert the trademark symbol in 
the document.

14. By default, the AutoCorrect Options are enabled. To disable AutoCorrect, repeat steps 
1–4 to open the AutoCorrect Options dialog box. Click to clear the check mark from 
Replace text as you type. The feature is off and the Automatically Use Suggestions 
from the Spelling Checker option is shaded gray to show that it’s unavailable. To 
enable the AutoCorrect function, click the check box again; a check mark appears in the 
box and the Automatically Use Suggestions from the Spelling Checker option again 
becomes available. (Check with your instructor to determine whether you should leave 
AutoCorrect disabled or enabled.)

5.2.2

How do you enable or 
disable AutoCorrect?
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 244 Lesson 9

15. Click the Exceptions button. The AutoCorrect Exceptions dialog box opens (see 
Figure 9-8).

16. Click the INitial CAps tab and key IDs, then click the Add button. Click OK to close the 
AutoCorrect Exceptions dialog box.

17. Click OK to close the AutoCorrect dialog box, and then click OK to close the Word 
Options dialog box.

18. At the end of the fourth paragraph, key Employee IDs will be provided to you on 
location. Adding IDs to the exceptions will avoid fl agging the word.

19. Click OK to close the AutoCorrect Options dialog box. Click OK to close the Word 
Options dialog box.

20. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

INSERTING AND MODIFYING COMMENTS IN A DOCUMENT
Word’s Comment feature enables reviewers to insert comments or questions in documents with-
out interrupting the fl ow of existing text. A markup keeps the original document along with 
changes made, such as comments. The right side of the document is shaded in gray and is the 
markup area. Balloons are markups used for comments made in the document and appear as 
colored balloons on the right side of the document. On the Review tab, using the Comments 
group (Figure 9-9), comments can be placed inline with text, which is another form for dis-
playing the markup. Word labels each comment balloon with your initials and the sequential 
comment number.

Figure 9-8

AutoCorrect Exceptions
dialog box

You can add and 
delete your own 
abbreviations.

You can add and delete 
your own personalized 
initial caps in words.

You can add other 
corrections with an 
option to delete.

5.2.1

How do you add or delete 
text in the AutoCorrect 
Exceptions dialog box?

The Bottom Line

Figure 9-9

Comments group
Move to Previous Comment

Add New Comment

Delete Comment

Move to Next Comment
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Inserting, Editing, and Deleting a Comment
You use the commands in the Comments group to insert and delete comments, and to move 
among comments in a document. You can edit or delete comment text by clicking and typing 
directly in the comment or by using the shortcut menu. In this exercise, you learn to insert, edit, 
and delete comments.

STEP BY STEP Insert, Edit, and Delete a Comment

USE the document from the previous exercise.

1. In the fi rst sentence of the second paragraph, select $55,000.

2. Click the Review tab and, in the Comments group, click the New Comment button. A 
comment balloon appears in the right margin of the document, labeled with initials 
and the comment number. (Later in this lesson, you will learn how to change these 
initials to match your initials.)

3. Key Will you please confi rm if the salary is correct? (see Figure 9-10).

Figure 9-10

Document with comment

Markup Area displays 
Comments balloons.

4. In the fi rst sentence of the third paragraph, select $2,500.

5. In the Comments group, click the New Comment button; a second comment balloon 
appears in the right margin, labeled with initials and a number.

6. In the new comment balloon, key The relocation amount is $5,000.

7. Click the Previous button in the Comments group to move back to the fi rst comment.

 8. Place the insertion point at the end of the text in the fi rst comment, and key 
I need a response by 5 pm today. You have edited the comment by adding more 
information.

9. Click the Next button in the Comments group to move to the second comment 
balloon. Click the Delete button drop-down arrow in the Comments group, 
and then select Delete from the drop-down menu, as shown in Figure 9-11. The 
comment is removed, and Word renumbers any subsequent comments in your 
document.

5.3.1

How do you insert
a comment?

5.3.2

How do you edit a 
comment?
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 246 Lesson 9

 10. SAVE the document as employment_offer_comments in your USB fl ash drive in the 
lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Figure 9-11

Comment Delete menu

Removes all 
comments in  
the document

Delete All Comments 
Shown

Deletes selected 
comment

 Another Way
 You also can 
delete a comment by right-
clicking on it and selecting 
Delete Comment from the 
shortcut menu.

5.3.3

How do you delete a 
comment? VIEWING COMMENTS

By default, Word displays comments in balloons, but it also can display inline comments in 
ScreenTips or in a separate reviewing pane. Inline comments are hidden; the reviewer’s initials 
appear in brackets beside the selected text. The Show Markup menu allows you to change how 
comments appear and to determine which reviewers’ comments are displayed. You can use the 
Track Changes drop-down menu to add your user name and initials to the list of reviewers. 
When in Draft view, certain elements in a document are not visible.

Viewing Comments Inline and as Balloons
and Hiding and Showing Reviewer Comments
In this exercise, you learn to change the comments display from inline to balloons. You also learn 
how to change the User Name that Word displays with comments added from your computer, 
to display the names of all reviewers who insert comments in your document, and to turn the 
display of their comments on or off.

STEP BY STEP  View Comments Inline and as Balloons and Change the User Name

USE the document open from the previous exercise.

 1. Click the Review tab and in the Tracking group, click the Track Changes drop-down 
arrow, then select Change User Name. The Word Options dialog box opens, as shown 
in Figure 9-12.

The Bottom Line

Figure 9-12

Word Options

Your initials will 
display in the 
Comment balloon.

Personalize by 
adding your name.
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2. In the Personalize Your Copy Of Microsoft Offi ce section, key [your name] in the User 
Name box, then key [your initials] in the box below. Click OK to apply your changes 
and close the Word Options dialog box.

3. By default, Word displays comments and formatting in balloons, as shown in Figure 
9-13. Deletions and additions to text appear inline and when in Draft view, these are 
also shown inline.Figure 9-13

Show Markup

Word’s default option for 
displaying comments

4. In the Tracking group, click the Show Markup button drop-down arrow to display 
the menu. Options are available on how markup should display in the document. 
Select Balloons, then Show All Revisions Inline. Inline comments are hidden and 
indicated by bracketed reviewer initials beside the selected text, as shown in
Figure 9-14.

Figure 9-14

Reviewer initials

Comments are hidden 
and revisions are 
displayed Inline.

5. Position the mouse pointer over your initials. The comment appears in a Screen Tip, as 
shown in Figure 9-15.

6. In the Tracking group, click the drop-down arrow in the Show Markup button; select 
Balloons, then Show Revisions in Balloons. The comment is shown in a balloon in the 
Markup area. If there are formatting revisions and text changes in this document, only 
the comments will display in balloons.

7. SAVE the document as employment_offer_comments2 in your USB fl ash drive in the 
lesson folder and close the fi le.
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 248 Lesson 9

8. OPEN the initial_employment_offer document in the lesson folder. The document 
opens with the default settings displaying comments and formatting changes in
the markup area.

9. In the Tracking group, click the Show Markup button drop-down arrow and select 
Reviewers; then in the drop-down list of All Reviewers, click the check box beside 
LE Silva to remove the check mark. His comments no longer are displayed in the 
document, as shown in Figure 9-16.

Figure 9-15

Comment displayed
in ScreenTip

Hover the cursor over 
reviewer’s initials to 
read hidden comments.

          The initial_
employment_offer 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

Figure 9-16

Document displaying only
one reviewer’s comments

5.3.4

How do you view comments 
from other reviewers?

5.3.4

How do you view
comments inline?
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 Proofi ng Documents 249

5.3.4

How do you view comments 
as balloons?

10. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Displaying the Reviewing Pane
Comments are listed in sequence and tracked on the Reviewing Pane either vertically or hori-
zontally on your screen. When the Reviewing Pane opens, a summary displays the number of 
insertions, deletions, moves, formatting, and comments that have been made in the document. 
In this lesson, you learn to change the review pane’s display from vertical to horizontal.

STEP BY STEP Display the Reviewing Pane

USE the document that is open from the previous exercise.

1. Click the Review tab and in the Tracking group, click the Reviewing Pane drop-
down arrow, and select Reviewing Pane Horizontal from the drop-down menu. The 
comments now display in a horizontal pane across the bottom of the Word window, as 
shown in Figure 9-17.

Figure 9-17

Reviewing Pane Horizontal

Comments by (sw ) 
and numbered

Summary detail 
number of revisions 
made in document 

Resize Reviewing Pane to 
view additional revisions.

Date and time 
comments were 
modified and saved

Reviewer’s full 
name appears

2. To view the Reviewing Pane vertically, repeat step 1 and select Reviewing Pane 
Vertical. The Reviewing Pane will display vertically along the left side of the document.

3. Click the X on the Vertical Reviewing Pane to close or click the Reviewing Pane button 
to close.

4. SAVE the document in your USB fl ash drive in the lesson folder and close the fi le.

STOP. CLOSE Word without saving.

SKILL SUMMARY

In This Lesson 
You Learned How To: Exam Objective Objective Number

Validate content by using Set grammar. 5.1.1
spelling and grammar Set Style options. 5.1.2
checking options

Confi gure AutoCorrect Add or remove exceptions. 5.2.1
settings Turn AutoCorrect on and off. 5.2.2

Insert and modify Insert a comment. 5.3.1
comments in a document Edit a comment. 5.3.2

 Delete a comment. 5.3.3

View a comment View comments. 5.3.4
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 250 Lesson 9

Knowledge Assessment

True/False
Circle T if the statement is true or F if the statement is false.

T F  1.  The proofi ng screen contains options to change how Word corrects and 
formats text.

T F  2.  You can change your name and initials in the Tracking group.

T F  3.  You should always proof documents before sharing them.

T F  4.  AutoCorrect can be found in the Backstage view Display option.

T F  5.  By default, comments are shown inline.

T F  6.  AutoCorrect cannot be turned off.

T F  7.  Inline comments are placed in curly brackets.

T F  8.  You can right-click on a comment and use the shortcut menu to delete 
the comment.

T F  9. The default Writing Styles setting is Grammar and Styles.

T F 10.  The status bar contains a proofi ng error button for quick access.

Multiple Choice
Select the best response for the following statements.

 1. The proofi ng option, Two Initial Caps, is found in which option?

a. CorrectCaps

b. AutoCorrect

c. Grammar Settings

d. Exceptions

 2. Which command(s) open the Spelling and Grammar feature?

a. F7

b. Shift�F7

c. Spelling and Grammar button

d. a and c

 3. Exceptions can be added to AutoCorrect

a. By not capitalizing the fi rst letter of an abbreviation

b. By ignoring the INitial CAps

c. Other Corrections

d. All of the above

 4. Comments are used to add _____ to Word documents.

a. Concerns

b. Questions

c. Reminders

d. All of the above

 5. The Comments ScreenTips appear in which view?

a. Showing Revisions in Balloons

b. Show All Revisions Inline

c. Show Only Comments and Formatting in Balloons

d. ScreenTips display only on the Ribbon
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6. How do you display only one reviewer’s comments in a Word document containing 
multiple reviewers’ comments?

a. Leave the check mark in the All Reviewers check box.

b.  Deselect the All Reviewers check box and place a check mark beside only that one 
reviewer’s name.

c. This feature only displays all reviewers’ comments.

d. This feature cannot display one reviewer’s comments.

7. The Vertical Reviewing Pane displays

a. To the right of the document

b. Below the Ribbon

c. To the left of the document

d. Above the status bar

8. A summary of the total number of comments in a document will appear in the

a. Vertical Reviewing Pane

b. Horizontal Reviewing Pane

c. Status bar

d. a and b

9. The Personalizing Your Copy Of Microsoft Offi ce options

a. Are located in Backstage view

b. Are located in the Tracking group

c. Cannot be changed

d. Automatically change when Word is launched

10. You can insert comments in which of the following types of documents?

a. Research papers

b. Resumes

c. Marketing plans

d. All of the above

Competency Assessment

Project 9-1: Research Paper
You are writing a paper about the health benefi ts of wine and are ready to check the spelling in your 
document.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN the benefi ts_of_wine document from the lesson folder.

 2. On the Review tab in the Proofi ng group, click the Spelling and Grammar button.

3. Click the Options button in the Spelling and Grammar dialog box to change the 
Writing Style. The Word Options screen opens in Backstage view. Select Proofi ng 
and under the section When correcting spelling and grammar in Word, click the 
drop-down arrow beside the Writing Style command box and select Grammar Only. 
Click OK.

 4.  The Spelling and Grammar check will stop on the words/phrases listed in the 
following table; for each misspelled word, take the action indicated in the table.

The benefi ts_of_
wine document fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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 252 Lesson 9

 5. When the prompt appears stating that the spelling and grammar check is completed, 
click OK.

 6. SAVE the document as benefi ts_of_wine_fi nal in your USB fl ash drive in the lesson 
folder.

LEAVE Word open for the next project.

Project 9-2  Books and Beyond Handbook
You work for Books and Beyond and the manager needs your assistance in using the AutoCorrect 
Options in Word. Your task is to manually proof the document and locate the six occurrences of Books 
and Beyond. You will be using the AutoCorrect to add © after Books and Beyond for each occurrence.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN the handbook_acknowledge document in the lesson folder.

 2. In the fi rst paragraph, fi rst sentence, place your insertion point after d in Beyond. 
Key (C) to insert the copyright symbol in the document.

 3. In the fi rst paragraph, second sentence, place your insertion point after d in Beyond. 
Key (C) to insert the copyright symbol in the document.

 4. In the second paragraph, second sentence, place your insertion point after d in 
Beyond. Key (C) to insert the copyright symbol in the document.

 5. SAVE the document as handbook_acknowledge_update in your USB fl ash drive in the 
lesson folder.

LEAVE the document open for the next project.

Misspelled Word Corrected Word Action to Take

Choleterol cholesterol Change All

polyphenl Polyphenol Change All

But what about white wine?  Ignore Rule

Stuttaford  Ignore All

Healthspan  Ignore All

Teissedre  Ignore All

The USDA makes it clear. . .  Ignore All

cancers  Ignore All

Agatston  Ignore All

The handbook_
acknowledge document 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

Profi ciency Assessment

Project 9-3: Books and Beyond Handbook Review
Sonny is one of the managers at Books and Beyond and has asked you to comment on the document.

 GET READY. LAUNCH Word if it is not already running.

 1. For every occurrence of Books and Beyond, add the following comments: The document 
should be consistent throughout. Consider using B & B throughout or spell out.

 2. Locate the title The Vice President of Operations and add the following comment: 
The Vice President of Operations is replaced with the new title, Vice President of 
Support Services.

 3. SAVE the document as handbook_mycomments in your USB fl ash drive in the lesson 
folder.

LEAVE Word open for the next project.
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Project 9-4: Showing Comments as Inline
Sonny is out of town and is interested in reviewing any comments you may have regarding the 
handbook. You will be emailing this document to him with comments displayed as inline. You will be 
working with the previous document from Project 9-3.

 GET READY. LAUNCH Word if it is not already running.

 1. Change the Show Markup settings to display comments as inline only.

2. SAVE the document as handbook_inline_comments in your USB fl ash drive in the 
lesson folder and close the fi le.

LEAVE Word open for the next project.

Mastery Assessment

Project 9-5: Blue Yonder Airlines Stock Agreements
Blue Yonder Airlines employs you, and one of your recent responsibilities is proofi ng all documents. 
The stockholders agreement document contains many misspelled words. Use the Spelling and Gram-
mar check to correct the misspellings.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN the stock_agreement document from the lesson folder.

 2. Locate all errors and correct them.

 3. SAVE the document as stock_agreement_fi nal in your USB fl ash drive in the lesson 
folder and close the fi le.

LEAVE Word open for the next project.

Project 9-6: Job Description
The job descriptions for fl ight attendants have been emailed to all fl ight attendants for their com-
ments. Review the comments and display comments inline with the vertical reviewing pane.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN the fl ightattendant document from the lesson folder.

2. Change the comments to display as inline.

3. Display the reviewing pane vertically.

4. SAVE the document as fl ight_attendant_comments in your USB fl ash drive in the 
lesson folder.

CLOSE Word.

The stock_
agreement document fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

The fl ightattendant 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

INTERNET READY

In this lesson, you learned how to confi gure AutoCorrect. 
You would like to fi nd additional information about this tool 

that Microsoft may have. Access the Microsoft website and 
select three links of your choice and prepare a short two-page 
report to provide to your instructor.
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